Help Desk Software & Beyond
August 18, 2017, 02:30:55 PM *
Welcome, Guest. Please login or register.
To post messages you need to register. We apologize for inconvenience, but this is to prevent spam.
Registration is instant (no email verification) and we do not ask for any personal information.

Login with username, password and session length
News: Welcome to Help Desk Software forum!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: ISAPI and CGI Restrictions in IIS7  (Read 75918 times)
egg
Newbie
*

Karma: 0
Posts: 10


View Profile
« on: May 20, 2010, 08:13:59 PM »

Im trying to run TTX on Windows 2008 with IIS7.  To the best of knowledge I think I have got the .cgi, .pl, and .pm extensions set up correctly.

I receive a 404.2 error though, that says
The page you are requesting cannot be served because of the ISAPI and CGI Restrictions list settings on the Web Server.

Has anyone had success with setting up a restriction for TTX?

Thanks so much,

egg
Logged
egg
Newbie
*

Karma: 0
Posts: 10


View Profile
« Reply #1 on: May 21, 2010, 04:31:59 PM »

This is from a discussion I had with a user on here.  Thought I would share.  I got it working on Win 2K8 R2 with IIS7.


***********************
Thanks for you quick reply.  I keep getting a 404.2 error.  Stating "The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server."

I pointed the CGI restriction to system32\inetsrv\cgi.dll

Is there anything else special you did to the directory.

*******************

I went into IIS and in the ISAP and CGI restrictions I gave or changed access to setup.pl and ttx.pl to ALLOW...

*********************

Hi, thank you.  I dont seem to have any .pl files.  I have setup.cgi and ttx.cgi.  Everything else is .pm.

Any thoughts?

*******************

rename ttx.cgi to ttx.pl.. and give that access to ALOWW


*************

Hope this helps someone else!!
Logged
prashant
Newbie
*

Karma: 1
Posts: 1


View Profile
« Reply #2 on: January 30, 2012, 08:34:23 AM »

Hello,

You may refer the URL : http://mywindowsblog.com/?p=587 In order to solve your problem .
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1 RC3 | SMF © 2001-2006, Lewis Media Valid XHTML 1.0! Valid CSS!
Page created in 0.015 seconds with 19 queries.